Back to overview
Downtime

Panel down

Mar 18, 2026 at 9:51am UTC
Affected services
panel.sennetjeeh.lol

Resolved
Mar 18, 2026 at 10:21am UTC

We’re back! server[s] should be up and running. Thanks for bearing with us.

Created
Mar 18, 2026 at 9:51am UTC

Our panel is down for most users. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.